EFOSC2 

ESO Faint Object Spectrograph and Camera
 
 
  
XMOS -- The MOS Slitlet Defining Tool

Starting the MOS mask tool
MOS mask tool menu options
Making a mask - Using the MOS mask tool
Some considerations
Starting with the MOS Mask Tool

Given below is a recipe for defining slitlets starting with an image  (EFOSC_Image.#.fits ). The phrases in green represent actual computer commands to be typed in as such apart from the usual substitutions for phrases enclosed within <angular brackets>:

The MOS mask definition tool is basically a panel which provides an interface between the user and MIDAS. Apart from the MOS mask definition tool (click on link to see the panel) 2 other windows are opened, a MIDAS display window and a MIDAS message window where the commands and their output are reflected.
MOS Mask Tool Menu Options

Listed below are the various menu options available and a brief description of the same. After that will follow a continuation of the recipe for defining the slitlets.
 

Load and R90 EFOSC*.fits Image The slits are defined in XMOS along the vertical direction. Thus an EFOSC2 image has to be rotated by 90 deg to make it compatible with XMOS convention. This option pops up a file selection panel and the selected FITS file is rotated and converted into a MIDAS file (Image_R##.bdf) and loaded on the XMOS display.

Send Mask Files to mos@w3p6ins This option pops up a file selection panel to send slitlet mask files (EFOSC_ R##.mask in the sub-directory ./EFOSC-MASKS) to mos@w3p6ins:/vltdata/tmp/EFOSC-MASKS. This is to be carried out at the end of the slit design process. If for whatever reason this does not work contact the support astronomer and/or do this FTP manually.

Load *.bdf Image If one wants to load the same image a second time one can load the already existing  *.bdf image instead of repeating the rotation of the FITS image described earlier.

Quit quits XMOS.

On Cursor  With this option the x-pixel location of the slitlet will be defined by the crosswire cursor position. One will want to use this option for very faint/diffuse objects on which the next option will not work. A click of the left button of the mouse will select the pixel under the cursor.  Any number of objects can be chosen one after the other and the function can be terminated by double clicking the middle button of the mouse.

On Object With this option the x-pixel location of the slitlet will be defined by a gaussian centroid fit to an object. The object area can be defined by the user by the help of the rectangular cursor provided when this option is chosen. The size of the rectangular cursor can be changed using the arrow keys to enclose as much of the object as possible while excluding its neighbours. After positioning the rectangle the object can be selected by clicking the left button of the mouse. Any number of objects can be chosen one after the other and the function can be terminated by double clicking the middle button of the mouse.

Delete Delete a previously defined slitlet. Select this option and left click close to an existing slit to erase it -- it will still be displayed until Colour->Clear and Masks->Show All are selected. One can continue to delete slits one after another until terminating the function by double clicking the middle button on the mouse.

Quick Look  Shows the slitlets defined so far.

Show All  Shows the slitlets plus a pair of parallel lines extending all across the CCD defining the upper (yellow) and lower (green) extent of the slit. This is useful to see if there is an overlap between slits which is to be avoided.

Load Mask  Pops up a panel to select a previously defined mask (./Image_R##.msk) for display and further editing

Reset  Erases all the slitlets defined so far. Previously unsaved work will be lost

Edit Mask  Pops up an ascii editor of the mask file

Print Mask  In an ideal world dumps the display (the background image + defined slits) on to the nearest printer. However for the moment it only creates a postscript file in the current directory (always named screen34.ps - will be overwritten each time this option is selected). This file can be printed with the command  lp screen34.ps. It is important that the image display is in the front of the screen, and not obscured by another window. (Oct 2002: the printer is not setup on wlsmos at the moment-- please ftp the postscript file to another computer for printing.)

Save Mask  This saves the existing slitlet configuration into 2 equivalent files:  ./Image_R##.msk and EFOSC-MASKS/Image_R##.mask. The first file is comprehensible to the MOS mask defining tool (can be reloaded for further work using Mask->Load Mask) while the second is to be used for actual punching  (i.e. the file which is sent by Efosc->Send Mask to mos@w3p6ins:/vltdata/tmp/EFOSC-MASKS/). Every subsequent saving of a mask file for the same image will increment the number in mask name.

Zoom  Use this to zoom in on a subsection of an image - useful in selecting blended objects and careful placing of slits such that they do not overlap. Select this option and then define the zoom area by clicking the left mouse button on the two opposite corners. The zoom will always maintain the aspect ratio.

Unzoom  Select this to display the whole image. Note that when this option is used all the graphics will be cleared and will have to be displayed again.

Scroll Use this to change the centre of display. Select this option and click left mouse button on the desired location to move it to the centre.

Next Slit  Scrolls the display such that the next slit moves into view (in a zoomed display, for example)

Cut  Useful (though rather unwieldy) for changing the intensity cuts of the image display. Select this panel and left-click on two pixels - the intensities of the two pixels will define the lower and upper intensity limits with which the image will be redisplayed.

Colour 1-8   Different colours in which slitlets can be shown.

Clear   Selecting this clears all graphics - the only way to remove dead wood. Deleted slitlets will remain on the display until they are Cleared and the redisplayed using Masks->Show All

Slit Length  Has two sub-options :
  • Minimum   The slit length defined is the minimum corresponding to the length of the punch tool used
  • Variable   The slit length is defined by the user. Care should be taken to ensure that this length is longer than the minimum length of the punch tool
Punch Tool This should not be changed for any single mask and has to be defined at the beginning before loading the image. It has 3 sub-options :
  • #1: 1.15" width  /  7.8" length  at EFOSC2
  • #4,5,8: 1.35" width  /  11.5" length at EFOSC2
  • #6,7: 1.75" width  /  11.5" length at EFOSC2
  • #3: is not a valid EFOSC2 option
Distortion Correction   has no effect as of now-- set it to NO.
back to top
Making a mask -- Using the MOS mask tool
  • Select a valid punch tool option --  Note this has to be the first operation after opening the tool and cannot be changed while working on a mask.
  • Load an image using either the Efosc->Load and R90 .....  option to select FITS files or File->Load *.bdf  to load rotated before
  • Change the values for the two parameters listed below and then click on Update Midas on the panel:
  • Change the display intensity cuts Tools->Cuts  to something sensible.
  • There are 4 possible slitlet defining operations. First select Options->slit length and then Slit->object/cursor option:
  • Some of the commonly used functions include:
  • Finally after everything is done:
  • back to top
    Some Considerations

    The 3 reference stars

    Slits to the right of centre will yield a spectrum which covers a range blueward of a central slit while those to the left will cover redder wavelengths.

    There is no spatial restriction on the location of targets on the CCD other than for the reference stars. However if you are using the narrowest punch be prepared to lose 1 or 2 objects close to the margins of the CCD especially if your reference star locations are less than perfect.

    back to top


    Send comments to : ls-spectro

    Last modified: Thu Oct  3 00:33:53 CLT 2002

    [3.60 & CAT Homepage][La Silla][ESO][Observing][Search][Help][News]