XMOS -- The MOS Slitlet Defining Tool

Table of Content


Starting with the MOS Mask Tool

Given below is a recipe for defining slitlets starting with an image  (EFOSC_Image.#.fits ):

  • Login as mosntt@wlsmosd (ask your System Engineer for password).
  • Create an unique working directory for your masks: cd users
    mkdir <yourname>
    cd <yourname>
  • ftp the fits image to this directory
  • Opens the tool with which one defines the slitlets: xm important: do not use the command xmos

The MOS mask definition tool is basically a panel which provides an interface between the user and MIDAS. Apart from the MOS mask definition tool (click on link to see the panel) 2 other windows are opened, a MIDAS display window and a MIDAS message window where the commands and their output are reflected.

MOS Mask Tool Menu Options

Listed below are the various menu options available and a brief description of the same. After that will follow a continuation of the recipe for defining the slitlets.

  • Efosc menu
    • Load and R90 EFOSC*.fits Image The slits are defined in XMOS along the vertical direction. Thus an EFOSC2 image has to be rotated by 90 deg to make it compatible with XMOS convention. This option pops up a file selection panel and the selected FITS file is rotated and converted into a MIDAS file (Image_R##.bdf) and loaded on the XMOS display.
    • Send Mask Files to mos@wefosc This option pops up a file selection panel to send slitlet mask files (EFOSC_ R##.mask in the sub-directory ./EFOSC-MASKS) to mos@wefosc:~mos/MOS/ and mos@wefosc:~mos/MOS/PIXMASK/. This is to be carried out at the end of the slit design process. If for whatever reason this does not work contact the support astronomer and/or do this FTP manually.
  • File menu
    • Load *.bdf Image If one wants to load the same image a second time one can load the already existing  *.bdf image instead of repeating the rotation of the FITS image described earlier.
    • Quit quits XMOS.
  • Slits menu
    • On Cursor  With this option the x-pixel location of the slitlet will be defined by the crosswire cursor position. One will want to use this option for very faint/diffuse or extended objects on which the next option will not work. A click of the left button of the mouse will select the pixel under the cursor.  Any number of objects can be chosen one after the other and the function can be terminated by double clicking the middle button of the mouse. If the variable slit length option is selected, two clicks are needed to define a slit.
    • On Object With this option the x-pixel location of the slitlet will be defined by a gaussian centroid fit to an object. The object area can be defined by the user by the help of the rectangular cursor provided when this option is chosen. The size of the rectangular cursor can be changed using the arrow keys to enclose as much of the object as possible while excluding its neighbours. After positioning the rectangle the object can be selected by clicking the left button of the mouse. Any number of objects can be chosen one after the other and the function can be terminated by double clicking the middle button of the mouse. If the variable slit length option is selected, three clicks are required to define the slit position and limits.
    • Delete Delete a previously defined slitlet. Select this option and left click close to an existing slit to erase it -- it will still be displayed until Colour->Clear and Masks->Show All are selected. One can continue to delete slits one after another until terminating the function by double clicking the middle button on the mouse.
  • Masks menu
    • Show All  Shows the slitlets plus a pair of parallel lines extending all across the CCD defining the upper (yellow) and lower (green) extent of the slit. This is useful to see if there is an overlap between slits which is to be avoided.
    • Load Mask  Pops up a panel to select a previously defined mask (./Image_R##.msk) for display and further editing
    • Reset  Erases all the slitlets defined so far. Previously unsaved work will be lost
    • Edit Mask  Pops up an ascii editor of the mask file
    • Print Mask  Prints the image with masks overlaid to the colour printer in the control room.
    • Save Mask  This saves the existing slitlet configuration into 2 equivalent files:  ./Image_R##.msk and EFOSC-MASKS/Image_R##.mask. The first file is comprehensible to the MOS mask defining tool (can be reloaded for further work using Mask->Load Mask) while the second is to be used for actual punching  (i.e. the file which is sent by Fits->Send Mask to mos@wefosc:~mos/MOS/). Every subsequent saving of a mask file for the same image will increment the number in mask name.
    • Send SAVED Mask  This sends the last saved mask to wefosc:~mos/MOS/ and ~mos/MOS/PIXMASK/ for the punching and coordinates recording respectively.
  • Tools menu
    • Zoom  Use this to zoom in on a subsection of an image - useful in selecting blended objects and careful placing of slits such that they do not overlap. Select this option and then define the zoom area by clicking the left mouse button on the two opposite corners. The zoom will always maintain the aspect ratio.
    • Unzoom  Select this to display the whole image. Note that when this option is used all the graphics will be cleared the quick look of the current mask display.
    • Scroll Use this to change the centre of display. Select this option and click left mouse button on the desired location to move it to the centre.

      Next Slit  Scrolls the zoomed display such a way that the next slit moves into view.

    • Cursor Cut  Useful (though rather unwieldy) for changing the intensity cuts of the image display. Select this panel and left-click on two pixels - the intensities of the two pixels will define the lower and upper intensity limits with which the image will be redisplayed.
    • Cut  Cut the image display according to the content of the low and high cut fields on the xm GUI.
  • Colour menu
    • Colour 1-8   Different colours in which slitlets can be shown.
    • Clear   Selecting this clears all graphics - the only way to remove dead wood. Deleted slitlets will remain on the display until they are Cleared and the redisplayed using Masks->Show All
  • Options menu
    • Slit Length  Has two sub-options :
      • Minimum   The slit length defined is the minimum corresponding to the length of the punch tool used
      • Variable   The slit length is defined by the user in the Min slit length field of the GUI. Care should be taken to ensure that this length is longer than the minimum length of the punch tool.
    • Punch Tool This should not be changed for any single mask and has to be defined at the beginning before loading the image. It has 4 sub-options :
      • #1: Is no longer offered as this very narrow head broke too often
      • #4,5,8: 1.02" width  /  8.6" length at EFOSC2
      • #6,7: 1.34" width  /  8.6" length at EFOSC2
      • #3: 1.87" width  /  8.5" length at EFOSC2
    • Distortion Correction  (historical) has no effect as of now -- set it to NO.

Making a mask -- Using the MOS mask tool

  • Select a valid punch tool option --  Note this has to be the first operation after opening the tool and cannot be changed while working on a mask.
  • Load an image using either the Fits->Load and R90 .....  option to select FITS files or File->Load *.bdf  to load midas files that have been rotated before (not recommended!)
  • You may change the values for the parameters listed below and then click on Update Midas on the panel:
    • Object distance from Slit edge . This defines how close to the edge of a slitlet an object can be placed. Put in a value of choice
    • Interslit gap This defines how far apart in pixels adjacent slits have to be. If 2 slits are defined with their extremities closer than this value the first slit will be erased. This is to make sure that the spectra of 2 adjacent slits to do not overlap. However one can deliberately overlap the slitlets of the reference stars since their spectra are not used. For this one will have to specify a negative value here. Beware! You will have to take care to ensure by eye that the slitlets of the target sources do not overlap!
  • Change the display intensity cuts Tools->Cuts  to something sensible.
  • There are 4 possible slitlet defining operations. First select Options->slit length and then Slit->object/cursor option:
    • slit length minimum - On object  Select the object using the rectangular cursor described under Slits->On object. A slit of the minimum length will be drawn centred on the object selected. The cursor will then be ready for the next object  until the function is terminated by double clicking the central mouse button.
    • slit length minimum - On cursor  Select the pixel using the crosswire cursor and a slit of the minimum length will be drawn centred on it. The cursor will then be ready for the next object  until the function is terminated as described before.
    • slit length variable - On object   Selecting the object with the rectangular will define the x-pixel of the slit. The tool will then provide a crosswire cursor for marking (left mouse button) the upper and lower (y-pixel) limits of the slit. On completing one slit the tool will immediately provide a rectangular cursor to repeat the process with another object. The function can be terminated as described before.
    • slit length variable - On cursor  The tool provides a crosswire cursor for marking 2 points with a click of the left mouse button. The upper pixel will define the upper slitlet limit while the lower pixel will define both the lower slitlet limit as well as its x-pixel.  On completing one slit the tool will immediately provide a rectangular cursor to repeat the process with another object. The function can be terminated as described before.
  • Some of the commonly used functions include:
    • Slits->Delete
    • Tools->Zoom and Tools->Unzoom
    • Colour->Clear and Masks->Show All
    • Masks->Save Mask
    • Masks->Load Mask
  • Finally after everything is done:
    • Save the mask one last time and note down the mask name from the message window.
    • Get a hardcopy of the image display including the slit graphics. Print postscript file immediately - it will be overwritten. Mark the reference stars on it - this will be useful while identifying them at the time of MOS acquisition during the night.
    • Send the .mask file  to the punching machine  Mask->Send SAVED Mask, Fits->Send Mask mos@wefosc or manually ftp the .mask file to mos@wefosc:~mos/MOS/.

    Some Considerations

    The 3 reference stars

    • should be bright (does not have to be very bright but should stand out in a 20 second exposure)
    • should form a spread out triangle
    • should not be located close to the margins of the CCD
    • should always be centred in a slitlet of minimum length using Slits->On Object  option
    Slits to the right of centre will yield a spectrum which covers a range blueward of a central slit while those to the left will cover redder wavelengths.

    There is no spatial restriction on the location of targets on the CCD other than for the reference stars. However if you are using the narrowest punch be prepared to lose 1 or 2 objects close to the margins of the CCD especially if your reference star locations are less than perfect.

     
    You're on EPU
    View live page